Home Register Arcade Gallery Chatroom Members Search Today's Posts Mark Forums Read Log In
Go Back   Inside: SereneScreen Fan Forum > SereneScreen Products > Marine Aquarium 3 for Mac OS X
Notices

Reply
 
Thread Tools
Old 12-23-2014, 11:33 AM   #1
larofthelair
Registered
 
Join Date: Dec 2014

Location: San Francisco, CA
Posts: 3
Marine Aquarium screen saver quits

After the screen saver is running for a while, it quits and a default Mac screensaver starts running in its place. The Marine Aquarium screen saver quits after about 10-20 minutes (the screen goes off after one hour). I'm running Marine Aquarium 3.2.1 (874) on a MacBook Pro running Mac OS X, v. 10.9.5 (Mavericks). Any ideas why Marine Aquarium is quitting? Thanks.
larofthelair is offline   Reply With Quote
Old 12-27-2014, 03:42 PM   #2
Ralph
Retired
 
Ralph's Avatar
 
Join Date: Jan 2002
1 Highscore

Location: Edmonton Alberta Ca
Posts: 2,296
Only guessing as I know little about the Mac system.. But if this were to happen on Windows I would suspect a setting in Windows that starts a screen saver in xx minutes while the system thinks MA is running as a program.
In Windows we can run the MA in either mode, as a screen saver or.. a program. Perhaps... this is happening to you as well.

Ludwig Wittgenstein (1889 1951)
The limits of my language are the limits of my mind. All I know is what I have words for.
Ralph is offline   Reply With Quote
Old 12-29-2014, 04:37 PM   #3
Michael Babin
Mac Development
 
Michael Babin's Avatar
 
Join Date: Jul 2002

Location: Rowlett, Texas
Posts: 199
Have you checked the settings in System Preferences > Desktop & Screen Saver? Is Marine Aquarium 3.2 selected? What is the value of the "Start After" setting?

When the MA screen saver quits and another one starts to run, do any messages appear in the Console?
Michael Babin is offline   Reply With Quote
Old 01-05-2015, 02:09 PM   #4
larofthelair
Registered
 
Join Date: Dec 2014

Location: San Francisco, CA
Posts: 3
Screen saver crashes

After about 6:45, the screen saver does crash. Here's what the Console says:

1/5/15 11:57:16.975 AM com.apple.launchd.peruser.502[155]: (com.apple.ScreenSaver.Engine.42800[1888]) Exited abnormally: Quit: 3

and then:

1/5/15 11:57:17.022 AM launchservicesd[74]: Application App:"ScreenSaverEngine" asn:0x0-ee0ee pid:1911 refs=5 @ 0x7fd045850440 tried to be brought forward, but isn't in fPermittedFrontApps ( ( "LSApplication:0x0-0x1001 pid=63 "loginwindow"")), so denying. : LASSession.cp #1481 SetFrontApplication() q=LSSession 100005/0x186a5 queue

and finally:

1/5/15 11:57:17.022 AM WindowServer[91]: [cps/setfront] Failed setting the front application to ScreenSaverEngine, psn 0x0-0xee0ee, securitySessionID=0x186a5, err=-13066

There's a crash report, too, if that would be interesting to anyone (over 2500 words).
larofthelair is offline   Reply With Quote
Old 01-05-2015, 02:10 PM   #5
larofthelair
Registered
 
Join Date: Dec 2014

Location: San Francisco, CA
Posts: 3
Oh yeah, the screen saver is set to start after 5 minutes (which it does). But I've been invoking it using a Hot Corner.
larofthelair is offline   Reply With Quote
Old 01-09-2015, 06:41 PM   #6
Michael Babin
Mac Development
 
Michael Babin's Avatar
 
Join Date: Jul 2002

Location: Rowlett, Texas
Posts: 199
Yes, the crash report would be interesting. Please send it to:

mbabin@orderndev.com

Thanks.
Michael Babin is offline   Reply With Quote
Reply
Go Back   Inside: SereneScreen Fan Forum > SereneScreen Products > Marine Aquarium 3 for Mac OS X



Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 09:03 PM.


Powered by vBulletin®
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.