Inside: SereneScreen Fan Forum

Inside: SereneScreen Fan Forum (
-   Marine Aquarium 3 for Mac OS X (
-   -   Bug fix release imminent (

JimO'Connor 12-16-2013 11:36 AM

Bug fix release imminent
There are some bugs in the legacy mode of the new Intel integrated GPUs which have caused us some problems.

1) the logo in the crystal is black
2) the fish become ghosts randomly

I have the fix for this running now. It required dropping all OS's prior to Lion and significant changes to the drawing code, so if you're on older hardware or software I'm afraid you've seen the last update to the product.

If you've seen either of these bugs please reply here or message me and I'll get you a new build to try.

engelens 12-19-2013 01:30 PM

Still running smoothly
Nope... still running smoothly on my MaverX

AnneB 02-04-2014 07:43 PM

Ghost fish are interesting, but...
I'm running OS X 10.9.1 on a brand new Air and I'm seeing the ghost fish. I've changed the FPS a few times and also the number of fish and couldn't solve the problem so I came here. Glad the problem is not at my end and that a fix is in the works.

FWIW, it's an interesting effect -- you might consider keeping it as an option.

JimO'Connor 02-24-2014 08:46 PM

Hi AnneB,

No, the problem isn't with your machine, per se, it is with the graphics drivers' support for older style OpenGL code.

The fix will break backwards compatibility with older OSs, so we're going to release the fix for this in a feature update with a new version number, 3.3.

jerrycube 03-11-2014 02:57 PM

Hey, first time poster and long time user. I'm having trouble with version 3.2.1 and my new Mac Pro. Iv'e use Marine Aquarium on my old Mac Pro fine for years but on OSX 10.9.2 the app and screen saver refuse to save my CD code, I have the physical CD and code version. I put the code in and it seems to accept it but then when I try to change settings it asks again for the code. Even the TESTFISH code does this so it appears to not be saving the code to to the user prefs. I tired everything, reinstalling from scratch and wiping all the user prefs etc. to no avail. I'm hoping a new version might help me out but right now I can't make any changes etc. Thanks in advance.

JimO'Connor 03-15-2014 10:36 PM

New Mac Pro and 10.9.2
Please try to repair disk permissions using the Disk Utility "First Aid" tab. I just added a key code on 10.9.2 without problems on my 2013 Mac Pro.

jerrycube 03-15-2014 11:11 PM

Hey, thanks for the reply. I tried permissions before and nothing happened. I did have some ACL found but not expected, a benign issue, but removed those anyway but still nothing. My CD code is accepted, the OK button goes from grayed out and un-selectable to clickable and all and clicking OK seems to be accepted and the slide down sheet retracts but then it just asks for the code all over again right after. I've tried removing every vestige of the app and prefs and installing from scratch, with the CD mounted, without the CD mounted but nothing works.

JimO'Connor 03-15-2014 11:20 PM

Hmm. Nothing has changed with respect to this functionality in many years. Which CD do you have? I may need you to send me your upgrade code so I can try it myself. You can message me with it.

jerrycube 03-15-2014 11:39 PM

The jewel box says Version 3, I'll message you the code. I can send you a photo of the CD and jewel case with the code on it too if you want proof of ownership etc.

JimO'Connor 03-18-2014 04:02 PM

JerryCube let me know that he solved the problem before I got to look at it in any depth.

The copy protection logic doesn't like the CD being mounted over the network via CD sharing.

321liftoff 06-04-2014 02:01 PM

Has the new version 3.3 been made available?

F34R 06-28-2014 09:32 PM


Originally Posted by 321liftoff (Post 152163)
Has the new version 3.3 been made available?

I'm going with a "no".

I still have 3.2.1(874). I haven't seen, nor can I find, an updated build.

kenbewick 07-08-2014 07:58 PM

Under the News section it says 3.3 is available and when i try to download i still get 3.2... Is there a different way to get 3.3?

fxk8mc 04-25-2015 04:02 AM

Ghost fish
I am running a MacBook Pro Intel i7 2GHZ with OS Yosemite 10.10.3. It seems that I've tried every combination in settings but am still experiencing the ghost fish. Seems like there are faint outlines all over the screen that when the fish swims around/through that they are very faint like ghost. Any and all help is appreciated....

JimO'Connor 05-06-2015 05:54 PM

Ghost fish
Please reference this thread...

The onboard video in some machines have bugs when trying to emulate the older OpenGL specs.

All times are GMT -6. The time now is 05:31 AM.

Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.